Forum

This content is now out of date.

Visit Our Community

Importing a view

Hi,

A SQL query based view was created in YF UAT instance. Report was built on this and was working fine.Report takes around 10 mins to execute and give output.

We are facing issues while importing XML file of this View to PROD environment.Not sure why the query is getting executed while importing which takes a longer time and finally we had to kill the query from backend.

Let us know how to go about with this.

Thanks,

Suneetha
Hi Team,

Can you please look into this issue and provide a resolution
Thanks,

Suneetha
Hello Suneetha,

Sorry to see you are experiencing some performance issues
while attempting your import.

Without obtaining the YF log files it will be difficult for us
to investigate your issue.

In this case, it doesn't ever look like you are getting an error message
but the server just hangs, correct?

Can you send across the Info_threads results when you are experiencing this slow performance?
It will hopefully show us exactly what YF is doing at that very point in time.

This can be accessed by opening a new browser tab and adding it toYF URL. E.g, :
yellowfinserver:8080/info_threads.jsp.

Lastly, can you tell us which version and build of YF you are using?

It is probably best to send these results to us via email and reference the title
to this post. support@yellowfin.bi

Thank you!
Hi Kyle,

When I import the xml file, SQL query of the view is getting executed which takes time. Is this how its supposed to work in YF.

Is there a way to just import the view and not execute the query?

Thanks,

Suneetha
Hi Kyle,

When I import the xml file, SQL query of the view is getting executed which takes time. Is this how its supposed to work in YF.

Is there a way to just import the view and not execute the query?

Thanks,

Suneetha
Hi Suneetha,

did you try setting the max rows option to 1 row just for the import and then changing back afterwards? This isn't guaranteed to help because if there are lots of joins and cached filters etc. then Yellowfin has lots of validating to do and obviously having max rows = 1 won't help in that situation, however it's worth a try.

Please let us know how it goes.

Dave
Hi Dave,

We did try setting the max rows option but didn't help.

Is there an option to import without executing the query?

Thanks,

Suneetha

Hi Suneetha,

unfortunately no, in a nutshell that's just the way the Yellowfin import process works and there is no way around it.

Sorry I couldn't give you the answer you would have preferred to see.

regards,
Dave

Thanks for trying Yellowfin

Please complete the form below to request your copy of Yellowfin today.