Forum

This content is now out of date.

Visit Our Community

ORA-01017 when connecting Oracle database

Updated documentation can now be found via our YF community HERE



I'm quite new on this forum, actually this will be my first post. I have worked before with Yellowfin but I did not install Yellowfin with a repository on Oracle. Now I'm facing a connection problem to the Oracle database. It's also happening when I make a connection to a datasource.

I've added an screencapture from the connection settings.

My database is running on Oracle 12c, the server is Windows 2008 and the Yellowfin version is 7.1.

When I make a connection to the database by entering the right settings on the dos command line using SQL*Plus, the database can be reached. The only difference might be that hereby I'm using the Oracle 119 client tools.

I hope someone can help me fixing this problem.

Thanks in advance!

Regards,
Gert
Hi Gert

Sorry to hear you are fighting with the Oracle DB and Yellowfin.

I would like to start by having you send your log files folder to me zipped.
This way I can take a look and the files will also be available for the AUS team when they come on on their Monday.

The log folder is under
YellowfinAppdata

Thank you
Mark
Hi Mark,

All files in the logging folder C:Yellowfinappserverlogs are attached to this post.

Gert
Thank you for the logs Gert.

I will start looking through them.

Mark
Hi Gert

The error that stands out is �Invalid connection string format, a valid format is: "host:port:sid" �

-Could you give me a screen shot of your Connection section on the Data Source Details page please.
-Also a screen shot of the browser line where you are typing in the localhost and port.

Lastly, have you made any alterations to any of the Yellowfin files such as web.xml?

Thank you
Mark

Hi Mark,

Attached you can fin a screencapture from the Connection section on the Source Details. By using SQL Developer or SQL*Plus, connection can be made.

I didn't made any changes to the file web.xml.

I also had issues by using the Yellowfin application after succesfully creating a SQL Server database connection by using JDBC. These issues were solved by changing the read permission on the files in folder C:Yellowfinappserverlogs. These were read only for the user I'm using, now they are full access.

When I create a connection by using JDBC to Oracle, the same error appears.

I'm not sure if the file attached for the second bullet is correct.

--
We are using Oracle 12c, is the JDBC driver capable to read Oracle 12c databases?

Using the Generic JDBC connection ... still an error.


Regards,
Gert
Thank you Gert.

Let me have a look at your latest info.
If need be I will get the AUS team involved. They are on holiday for their Tuesday.

Mark
Hi Gert,

you can establish whether this is an Oracle problem or Yellowfin by trying to connect to your Oracle DB with a db tool such as DBVisualiser or SQuirreL.

By the way, I once had a similar problem to the one you're experiencing with creating a JDBC connection to Oracle (also had the same issue using DBVisualiser as well as Yellowfin) and managed to finally resolve it by using the connection string format that uses the service rather than the SID, for example:

[code]jdbc:oracle:thin:@//myhost:1521/myservicename[/code]

so as a trouble-shooting tool that would be an interesting thing to try.

I did some searching on the Oracle error message and found this web page which has quite a few different things to check, so if the above suggestions don't help then perhaps try working through the check list in that web page.

Please let us know how you get on.

regards,
Dave

Hi Dave,

Finally, it works!

As suggested I have installed DBVisualiser, this application works by using connection type TNS. I had to add a variable TNS_ADMIN on the server. After this I have restarted the YellowFin services, then I recreated the Oracle connection in YellowFin. Using the database Oracle and connection Method JDBC no working connection could be made, still the same error java.sql.SQLException: ORA-01017: invalid username/password; logon denied, I do have additional options like Schema and Isolation Level.

Now I'm using Generic JDBC Data Source as database, the connect string is now like this: jdbc:oracle:thin:@//ipadress:portnumber/service_name.

This results in a working connection!

Maybe the cause of the error using Oracle as Database might be the way the tnsnames is defined.
This issue can be closed, problem solved.
that's great news Gert! When I initially found that the service_name connection worked for me rather than the SID one, I was too busy to investigate why, I was just happy that it worked! However your idea about the definition of tnsnames sounds like a good place to start....when I have time!

regards
Dave

Thanks for trying Yellowfin

Please complete the form below to request your copy of Yellowfin today.