Forum

This content is now out of date.

Visit Our Community

Bug in “Configure Filters” In list operator

Hello,

I have countered a small bug which is quite irritating, but not a show stopper.

I have configured Yellowfin to use comma as the decimal separator and period as the thousand separator (Euro style).

Forum image

After this change while trying to create a filter from an integer dimension the changes above start to mess up the system. If I try to specify manually an integer which is in thousands (in "Configure Filters"), Yellowfin cuts the integer from the thousand separator. For example, if I try to specify with the In List operator the years 2014 and 2013 for the dimension "Year", the filter would be 2, 2. See image below:

Forum image

After which happens this:

Forum image

This problem doesn't seem to occur on Equal to operator, which handles the integer just fine. If you want the integers to work on In List operator, you have to add the integer with comma (2,014). Hope this helps.

Br. Simone
Simone,

Thank you for sending your issue through to the YF forum
and for including screenshots. This is always helpful.

I was able to replicate your issue in YF7.1, Sept build.

Can you please confirm which version and build of
YF you are using?

Thank you,

Kyle

Hi,

I just tested this on another Yellowfin istallation with August build and couldn't replicate the problem. Here are the specs of the yellowfin servers I tried this on:

Problem exists
Application Version: 7.1
Build: 20140923

Seems to work
Application Version: 7.1
Build: 20140827

About the operators, I haven't tried if this problem occurs with different ones too, not just 'In list'. Is it really necessary to put the thousand separator when specifying the filter? It's seems odd to have that when you're specifying a year.

Br. Simone
Deleted post.
Simone,

We have lodged a product defect for this, task #176640,
and hope to have this rectified in a future patch.

Thank you for pointing it out.

Kyle

Thanks for trying Yellowfin

Please complete the form below to request your copy of Yellowfin today.