Forum

This content is now out of date.

Visit Our Community

Can’t edit report, no draft version


Im facing the following problem: I was editing a report, and somehow I got locked out: I can't edit the report anymore when I'm in the Browse section; the icon for edit is just not there. Strangely, there isn't a Draft version anymore of this report, what normally would be the case. However I can start and view the report.

PS: I think in between I edited the underlying view, although Im not sure on the order on this I changed the view & reports. Im sure the view is activated.

Any ideas on how this is occured and how to fix this?
I am on Yellowfin 7.1
Hi Peter

Sorry to hear about the report frustrations.

If you're missing the 'edit' option, the first things you should look at are-

1 -Report Categories
Does this apply to all reports within specific categories?
If so it would be related to the report category security.

2 - Are you using Client orgs?
Items created at the default org cannot be edited from within a client org.
You will however be able to copy and then modify that copy.

If the above does not help, are you able to create a new report, and if so what report categories are you able to save it in?
Does this include the report category where your read-only report is?

Let me know if this info helps.

Thank you
Mark
Hi Mark,

Thanks for your help first of all!

I just tried the two things you mentioned, but without result unfortunately.
I also have a dashboard in the same (sub)category, and I can edit this one.

The client orgs functionality is not enabled and therefore not used.

When I create a new report in the same category as the read-only report, I can edit/delete it.
However the read-only report still lacks the edit option.

Btw:
- I do have administrator right with the account I use.
- I did quite some editing and activating on the report & underlying view, just to you know the situation in which the issue occurred.

Do you have any other ideas?
If you need more info or screenshots, let me know.

Thanks!
Peter


Hi Peter

Sorry for the delay.

Was wondering if you have attempted making a copy of that problem report? Then of course trying to see if the Edit button is available for it?

Screen shot wise,
if you could make a screen shot of the page where you do not see the Edit button I would like to show that to a co-worker here.

Thanks for the patience.
Mark
Hi Mark,

No problem, thanks for following up.

I can only delete the page, no option there for Edit. When I run the report, I can only create a New report, or Delete this one.

It seems I've been locked out, altough I am an administrator (and was also assigned to this report read/edit/delete-wise).

I've included the screenshot of the page where I don't see the Edit button (although I don't see the picture in this posted reply?)

Thanks,
Peter
Hi Peter

Thanks for the update.

No screen shot came thru.
Could you send it to support@yellowfin.com.au
Along with that in the subject line put
Yellowfin Support Forum - Can't edit report, no draft version

While I am waiting for that I will speak with a dev team member to see if we have had any other instances like this.
Which reminds me,
What build of this 7.1 version are you running?

Thanks for the patience.
Mark
Hi Mark,

I've just sended the screenshot.

I'm on build 20141223; below the system info from Yellowfin.

Application Version: 7.1
Build: 20141223
Java Version: 1.7.0_71
Operating System: Windows Server 2008 R2 6.1 (amd64)

Thanks,
Peter
Hi Peter

Thanks for the build info.
Guess what? Still not getting screen shot.
Try sending directly as a attachment in a separate email to support@yellowfin.com.au.

If you go to Administration, then Views and choose your active view I was wondering if you see the bad report in the list when choosing the Report tab?
Also when you initially go into that View does current status say Active?


Is that report with the issue a public report?
If so is there anybody there that has the Role of Public Writer or Corp Writer?
A person in that role has access to edit public reports.
Only reason I ask is to see if there is an issue with your Admin id on that report.

Thanks again
Mark

Hi Mark,

I just resend the mail, I think it got stuck in my mailbox.

When I go to Administration - Views, and I choose the active view in question, the status says 'Active'. The bad report is listed.

I'm not sure if I defined the bad report as Public..the user must login to view it, which is mentioned at the bad report properties list. Im not sure if its therefore secured/not private?

There isn't anybody with Public Writer or Corp Writer at the moment.
I just have 2 administrators and 3 report consumers; the other admin cant see the report at all..I think I didn't grant that admin on the bad report.

Thanks again,
Peter
Hi Peter

I got the attachment this time!

Question on it,
-Which report on that page is the one that will not edit?
-By the way, did this report exist before the latest 1223 build that you currently have? If so was it working then?

I am showing this forum post to a co-worker now to see if there is some other info that may be needed.

Thanks for info on the Active view verification.
Mark

Hi Peter

I have been discussing the issue with a co-worker from dev team.
Couple of things to check.

-is the View set to Unsecure?
Administrator-View- page 3.
I attached a screen shot.

-Could you get a screen shot of the page where you are in the View mode of the report but there is nothing where Edit should be?

There is a possibility that the single report is corrupt since you are able to create new ones and edit them.
With it being just one report you may have to just re-create it and delete that bad one.

Lets see if any of the above requested info gives us anything.

Thank you for fighting along with me!
Mark
Hi Mark,

We've got the problem solved!

To your questions:
- I did update to the latest build (from the previous build). I was not directly locked out after the upgrade although. I did change the user to login with their username instead of their email, maybe is has not to do anything at all with this
- It is the report in the far right-top in the screenshot

The view is secured, only certain users may update or delete it.
This setting did change over time (added other users, but didn't change my user) from public to restricted; I wasn't locked out after setting it to restricted as far as I remember.


Now: If I change the security of the view, by resetting the User, and set it to delete or update, then I'm capable again to edit the report. So I have the same rights as before, but somehow I works now.
I just had to re-define the view security appearently. Somehow in the process it got screwed up; how, no idea.


Thanks for helping out!
Peter
Hi Peter

Excellent to hear you now have access to the report!
With there being several security options available at different levels it sounds like something just got set inadvertently.

Great work with the sleuthing!
Mark
Hi all,

Just to add to this, I experienced the same issue after updating from 6.3 20150422 to 7.1 20150501. The way I fixed it was by editing the view in which the affected report had been created in, changing the radio button in the View Security settings from Unsecure to Restricted, and then back to Unsecure. From there, I simply activated the view and the report that could not be edited before could be edited again (i.e. the pencil symbol came back so the option to edit was visible).

I'm not sure if it contributed to the problem or not but as an FYI the view in question had half a dozen restricted columns. It seems to have only happened to that view but I will update if I notice it elsewhere.

Mike

Thanks for trying Yellowfin

Please complete the form below to request your copy of Yellowfin today.