Forum

This content is now out of date.

Visit Our Community

CONTENT_ not working

Hi Team,

We use the Single Sign On process to log a user into Yellowfin 7.1.

As part of development, we have tried passing the CONTENT_ parameter with login, but the Content Categories does not get filtered.

In my case, I have specifically tested passing the parameter as follows:

CONTENT_INCLUDE=Water

, where we have a content category spelled exactly like that.

I could not spot anything in the Yellowfin logs as to why this failed to filter content categories available to the user. Have tried admin as well as report consumer users.
Simply all content categories appeared under the Browse window.

Please advise as to how one should go about trouble shooting this?

Thanks and regards,
David
Hi David,

the trick is to set the CONTENT_INCLUDE/EXCLUDE parameter via the setParameters() method of the AdministrationServiceRequest. I've attached an example to demonstrate this to you. Please give it a try and let us know how you get on with it.

regards,
Dave

Thanks for trying Yellowfin

Please complete the form below to request your copy of Yellowfin today.