Forum

This content is now out of date.

Visit Our Community

Error after the Migration


hi,

We have a Yellowfin instance which uses mysql in our Linux box.Recently, we have migrated our yellowfin instance and DB to a new box.In our old setup both Yellowfin and DB were in the same box,but in the current set up we have moved our application to one box and DB to another box.

As a migration process, from application perspective, we took the tar of our existing application and moved to the new box and untarred it there and changed DB properties in web.xml of Yellowfin.From DB perspective we took the entire dump of old instance and loaded that dump into our new db instance.

After the migration Yellowfin is coming up but we are not able to login and when we checked the logs we are getting the below error.

YF:2015-01-27 01:12:00:ERROR (DBAction:doSelect) - Error occured selecting data: com.mysql.jdbc.exceptions.jdbc4.MySQLSyntaxErrorException: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'OPTION SQL_SELECT_LIMIT=DEFAULT' at line 1.


Please help us with above.

Thanks,
Mala
Hello Mala,

Sorry to see you are having some issues after your migration.

When you are receiving any type of YF system errors it is best
to send your issues through to support@yellowfin.bi for the
appropriate response and investigation.

We generally try to keep the Forum to general 'how to' issues.

If you can zip up all the YF log files through and send them to
the above email, that would be great. You can reference the title
of this Forum post if you would like.

When you send them through can you also let us know which
version and build of YF you are using? E.g. 7.0, NOV?

Thank you,

Kyle

Hi Mala,

I've got some additional information for you that was passed along
by another team member.

Your error means that the JDBC driver is the wrong version. If you could
download the latest MySQL JDBC driver and add it to your
YF installation that should hopefully fix your error.

Also, don't forget to remove the old driver as well.

Can you let us know how this all goes?

Thank you,

Kyle

Hi Kyle,

Thanks for the response.

The mysql connector in jdk had older version. We changed the connector to new version and later worked.

Thanks,
Mala
Mala,

Thank you very much for letting us know that this worked
out for you.

Cheers,

Kyle

Thanks for trying Yellowfin

Please complete the form below to request your copy of Yellowfin today.