Forum

This content is now out of date.

Visit Our Community

Error uploading a CSV via the Report Builder

Hi,

I keep getting an error when I try and upload a CSV file via the Report Builder.

I can get through the first step and it lets me view the file but when I click "Finish" I get the attached error.

I have tried removing all but one row and the same error occurs. There are no special characters in the text.

Any help appreciated.

Thanks,

Kathryn

Forum image
Adding to this we are connecting to a AWS redshift DB, the issue seems to be when the CSV import tries to import a VARCHAR. ie. using a very basic file that contains

VAR
1

it loads, but if it contains

VAR
far

it doesn't and produces the error mention by Kathryn

Cheers

Barry
Hi Kathryn & Barry,

This could be a known issue (175209) that was fixed in the October build of YF 7.1, so if you upgrade to the latest patch then hopefully the issue will be resolved.

And if for some reason you can�t immediately upgrade then for a workaround what you can do is to reconfigure your Redshift data source to use the PostgreSQL driver instead of the Redshift one then you should be able to import the CSV file into your Redshift data source.

By the way, the issue is caused by a LIMIT being appended to the query sent to the database rather than the database�s meta-data MAXROW being used

Please let us know how this goes.

regards,
Dave
Work around mentioned above worked... have yet to upgrade and test patch.

Thanks for you help on this

Barry

Thanks for trying Yellowfin

Please complete the form below to request your copy of Yellowfin today.