Forum

This content is now out of date.

Visit Our Community

Exception occured when opening some users

Hi !

Following exception occurred when opening some users (For instance System Administrator) in couple of Yellowfin systems. This issue exists in Yellowfin bild version 20140721 and 20140528.

Error: java.lang.NullPointerException
At:
com.hof.mi.process.MIUserProcess.loadUserGroups(MIUserProcess.java:706)
com.hof.mi.web.action.MIUsersAction.execute(MIUsersAction.java:496)
org.apache.struts.action.RequestProcessor.processActionPerform(RequestProcessor.java:484)
org.apache.struts.action.RequestProcessor.process(RequestProcessor.java:274)
org.apache.struts.action.ActionServlet.process(ActionServlet.java:1482)
org.apache.struts.action.ActionServlet.doPost(ActionServlet.java:525)
javax.servlet.http.HttpServlet.service(HttpServlet.java:643)
javax.servlet.http.HttpServlet.service(HttpServlet.java:723)
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
com.hof.servlet.BrowserHeaderFilter.doFilter(BrowserHeaderFilter.java:40)
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
com.tramada.servlet.TramadaYFp3pFilter.doFilter(TramadaYFp3pFilter.java:38)
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233)
org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191)
org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:103)
org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:293)
org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:861)
org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:606)
org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:489)
java.lang.Thread.run(Thread.java:662)




Forum image



Forum image


Please update us whether this issue relates to specific configuration or any other issue.

Thanks
Supun
Hi Supun,

Sorry for the inconvenience this has caused.
In future, just send through an errors/defects via email and attach the relevant screenshots/logs. We want to try and keep the forum for faqs and how-to's etc..


In terms of the error you're facing, it's a little weird as it looks like it's trying to load a user group that isn't actually there. And having it load a group, when clicking on a user account shouldn't be possible.

Are the affected users part of a broken group, or were changes made to a group they are part of etc..?

Also, can you please send across exports (in CSV/XLS) of the following tables to support@Yellowfin.bi, just reference this post;

-IpClass
-Person
-IpContact
-AccessGroup
-AccessGroupMembers
-IpRltshp

Thanks,
David

Thanks for trying Yellowfin

Please complete the form below to request your copy of Yellowfin today.