Forum

This content is now out of date.

Visit Our Community

How does refresh cached filters work

In most of my reports i use list in the filters to show the users what data is available in the data-set the report is built on. In this example it is about places/location employees have worked on specific dates. The data in the table (the worked hours with fields like customer and place/location) are added to the table in batches. So in one "batch" i get records in my table with existing and non-existing places/locations.

On the report-function i expected the function "Refresh cached filters" to renew the list and so add the new places/locations to my filter-list and eventually remove places from records that where removed or spelled the wrong way (e.g. New York vs. New-York).


Forum image

(The data in this example is processed on a MS-SQL Express database on Windows 8.1, the report is in the default-organisation)

When i enter the edit-mode of the report and activate a refresh then... alle values are there and my reports works fine in edit-mode

Forum image


However saving the report and opening the "life-version" shows me only the old-values.
On this report i use parameters, do i don't have the option to configure refreshing (Refresh Settings : Refreshing data is disabled on reports that have User Prompt filters)

When i go to the View and look at the filter-properties; the the lists are showing me the right and complete values. Saving the view (after forcing a refresh of the filter-list per filter-field) looks to be the solutions. After this "trick" all filter-values are there on my report

So the question is: how does the refresh-function work on the "filter-tab" (first screen-shot). And how should i define my views or reports to have the filter-list updated without an update of the view?



Can you explain how i have to configure
Hi Peter,

Thanks for the detailed info.

In short, any time you use 'Refresh Cached Filters' it should query the data source and then update the list.
So it looks to be a defect, though just trying to understand how your filter is setup so we can replicate your environment.

E.g. Is this a view level filter, part of a filter group.
Does this report live on the default org, and you're trying to refresh the report from within the client?

Once we have a good idea of how it's all setup we can test and raise accordingly.

Please let me know if you have any questions on this.

Regards
David

Hello David,

this issue is on my Windows 8.1 Machine with the data and repository stored in MS SQL Server Express database installed local. The problems with the refresh where there when in used version 7.0 (mai 2014) and still persist in the latest build of 7.1

It might be noteworthy that i also saw it happening on another database/system.

In most cases we succeed to fill the correct cache when we go to the view and refresh it there.
The most common place it happens is with a "catogery filters"; maybe it's even the only place it happens. In my example this is in the default-organisation. Hope this information helps to reproduce this behaviour.


Forum image



Forum image
Hi Peter,

Thanks for the extra info.

This is a defect (TASK ID = 174882) as the refresh option should actually refresh the cache filters,even if using a view level filter group.

I have marked it as HIGH, so hopefully can be fixed very soon, just hard to give an ETA as it needs to be allocated first, and have a funny feeling this may not be a quick fix :(.

Please let us know if there was anything else you were after in the meantime and apologies for the inconvenience this has caused.

Regards,
David



Thanks for trying Yellowfin

Please complete the form below to request your copy of Yellowfin today.