Forum

This content is now out of date.

Visit Our Community

How to enable Thousand Separator for all reports

Hi,

Is there a way to enable "Thousand Separator" report column settings globally ? We have already built 100s of reports without enabling this setting.


Forum image


Thanks
Supun
Hi Supun,

Hope you are well,

I have done some investigation in to this option and I am sorry to say that this option is currently unavailable. But I have logged an enhancement request for you. (Task ID #199726)

As soon as we have an update we will update this forum post

If you do have any further questions please feel free to contact us.

Thanks

Adam
Hi Adam,

Thank you for the reply.

As I mentioned earlier, we already developed 100s of reports and it will be a really tedious task to edit each report and configure numeric columns with the setting.

Therefore, I'd like to know, can this be done through a SQL script ?

Thanks
Supun

Hi Supun,

Hope you are well,

Sorry for the delay in contacting you, I have been working with my the other guys in the support team and we have found a workaround that should help with making the changes to the large number of reports that need to be changed.

1. Back up the Yellowfin Configuration Database

2. Stop the Yellowfin Service

3. Run the following SQL query against their Yellowfin Configuration Database:

UPDATE reportfieldparameter
SET parametervalue = 'True'
WHERE parameterkey = �THOUSANDSEPARATOR�;

4. Start the Yellowfin Service

Now, special note�this only works for fields that have been added to a report where that field has been formatted, or at least the format window has been opened. Yellowfin doesn�t create reportfield entries for a report if it can derive a field definition from the view instead. As soon as the report fields are formatted entries are created in the DB that can then be edited.

If you do require any further assistance please feel free to contact us.

Thanks

Adam

Thanks for trying Yellowfin

Please complete the form below to request your copy of Yellowfin today.