Forum

This content is now out of date.

Visit Our Community

Import drill down report using standalone tool

Hi

I've trying to import (replace not add as new) a report which has a drill down using the standalone utility:

java -cp com.hof.standalone.ImportData

Although above command outputs: "Replacing Report: Inbound Calls Report Drill Down", report is not replaced but added (I can see that in Browse list) and I am unable to even open that report.

Then I open the original report which supposed to be replaced and when I save that report (even though doing that as admin) I get: "You do not have sufficient access rights to run the selected report."

The strange thing is that another report in the YellowfinExport.xml file that has drill down as well is replaced successfully (it is not added in the Browse list and I can see all the changes I made to the report).

The differences between those 2 reports are the following:
- 1st report that is replaced uses standard YF Date Hierarchy drill down e.g. Year => Month => Day
- 2nd report that is added instead of replaced uses 2 varchar dimensions fields which are derived from different tables e.g. Queue Name => DNIS Number

Any idea why?

Application Version: 7.1
Build: 20141223


Thanks
Hi Stelios,

just letting you know that I have just tried to replicate this issue over here but so far without success. I used the demo DB (Ski Team) that comes with the Yellowfin installer, there is a hierarchy from the PERSON table:

Athlete Region -> Athlete Country,

and there also is another hierarchy from a different table (CAMP:

Camp Region -> Camp Country

And I mixed them up so that I had Athlete Region -> Camp Country.
Then I made a Drill Down report using that new drill down hierarchy from different tables, then exported it to an XML file, made a change in the Report Description so I could identify it uniquely, then imported it back in via the standalone import utility, making sure that the Replace All option was selected (rather than Add). And after that, the new version of the Drill Down report had successfully replaced the previous version.

I will play around with it some more tomorrow and continue trying to replicate the issue and will let you know how it goes.

regards,
David
Hello again Stelios,

just letting you know that I made further attempts at reproducing this issue today and still no luck! So I guess that most probably my drill-down report wasn't a good reproduction of yours and that's why my replication of the issue is failing, so I'm hoping that you can provide some detailed screenshots of the report so that I can see exactly how to produce a similar report. Or better than that would be if you could upload a backup of your YF config DB and also the schema (i.e. data not required) from your data warehouse, how do you feel about that? Please let me know.

Also, it's worth checking that you didn't have Yellowfin running when you were using the standalone import tool. And also, did you try importing the same report via the UI import facility? and if so, how did it go?

regards,
Dave

Hi Stelios,

just letting you know that I have restored your YF DB and also the data warehouse, and now have been able to replicate the ReplaceAll issue with the Standalone Import tool, so a product defect has been raised (193739) and I have added it to the agenda for the next developers' meeting for discussion and allocation.

regards,
Dave

Thanks for trying Yellowfin

Please complete the form below to request your copy of Yellowfin today.