Forum

This content is now out of date.

Visit Our Community

Installing YF 7.1 on SQL Server 2012

Hi,

Today I tried to install YF 7.1 on a SQL Server 2012 database, but untill now ... no success. I have created a new database a new user, specificly for YF. This is working well.

Starting the installation, I have selected Microsoft SQL Server Azure as database type. Obviously I think this is strange because it ain't SQL Server Azure but SQL Server 2012, the last one is not available in the list.

In the next step I have entered the information needed to connect to the database. User 'yellowfin' is available and is having admin rights, database is available with user 'yellowfin' as database owner.


Forum image


I have tested this database and user, it is all working well.

The option Validating is marked as Yes, after 95 seconds, the following error is listed:


Forum image

The first phrase is: Con not make connection by using user yellowfin.

After trying this a couple of times, I have created a repository by using the internal database type HSQLDB. This works fine, when I the created a database connection to the same database by using the same settings and credentials (by using JDBC) it all works fine ...

Now the questions:

1. What is going wrong?
2. Can SQL Server 2012 be used for storing a YF repository?
3. What specific actions must be made before installing?

Regards,

Gert



SQL server 2012 can be the repository database.

i can suggest the following steps :

1) create DB on sql named YFrepo
2) make sure you have a login/user with access to the DB
3) When installing yellowfin make sure:
a) you have the right server address - localhost or named instance ?
b) uncheck the Create database, write YFrepo as the repository database
c) Is is windows Authentication or SQL one ? check and make sure you
have the right user/pass .
d) make sure the port for SQL server is still 1433 (default)

shaul
Hi Shaul,

Followed all steps, but no succes. Tried localhost and 127.0.0.1. Also changed the hostst file on Windows. No succes. Database is accepting mixed mode for authorization. Als disabled the Windows firewall.

Below the settings for the connection:


Forum image


Hi Shaul,

To complete my previous comment as guest I want to make a replenishment. For all installations I made, I choose language "Nederlands". This langage only gave me the option Microsoft SQL Server Azure, I also tried language "English", after selecting this language a got an extra option: Microsoft SQL Server.

Below I added the screenprint for the connection setup screen. This is different to the previous image I have added.


Forum image


[color="#FF0000">I would suggest to check the correctness of the installer when language "Nederlands" is selected.[/color]

Case can be closed.

Regards,
Gert

Thanks for trying Yellowfin

Please complete the form below to request your copy of Yellowfin today.