Forum

This content is now out of date.

Visit Our Community

MessagingException: 501 HELO requires domain address

Hi,

I'm getting the following exception thrown when I either do an email test on the admin configuration page or try sharing a report:

[code]
YF:2014-07-25 15:17:44: INFO (MIAdminConfigAction:execute) - MIAdminConfigAction entered
YF:2014-07-25 15:17:45:ERROR (MIAdminProcess:testSmtpServer) - Error: javax.mail.MessagingException: 501 HELO requires domain address

javax.mail.MessagingException: 501 HELO requires domain address

at com.sun.mail.smtp.SMTPTransport.issueCommand(SMTPTransport.java:1308)
at com.sun.mail.smtp.SMTPTransport.helo(SMTPTransport.java:785)
at com.sun.mail.smtp.SMTPTransport.protocolConnect(SMTPTransport.java:327)
at javax.mail.Service.connect(Service.java:258)
at javax.mail.Service.connect(Service.java:137)
at javax.mail.Service.connect(Service.java:86)
at javax.mail.Transport.send0(Transport.java:150)
at javax.mail.Transport.send(Transport.java:80)
at com.hof.mi.process.MIAdminProcess.testSmtpServer(MIAdminProcess.java:11018)
at com.hof.mi.web.action.MIAdminConfigAction.execute(MIAdminConfigAction.java:630)
at org.apache.struts.action.RequestProcessor.processActionPerform(RequestProcessor.java:484)
at org.apache.struts.action.RequestProcessor.process(RequestProcessor.java:274)
at org.apache.struts.action.ActionServlet.process(ActionServlet.java:1482)
at org.apache.struts.action.ActionServlet.doPost(ActionServlet.java:525)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:643)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:723)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
at com.hof.servlet.BrowserHeaderFilter.doFilter(BrowserHeaderFilter.java:40)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233)
at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191)
at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:103)
at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:293)
at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:861)
at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:606)
at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:489)
at java.lang.Thread.run(Thread.java:662)
YF:2014-07-25 15:17:45: INFO (MIAdminConfigAction:execute) - MIAdminConfigAction exiting with action: success
[/code]

I have double checked the settings and they are correct. I have even tested the username and password using the webmail site to be sure. I have also checked that the SMTP Server hostname is resolvable on the Linux box and is not being blocked:

[code]
[bi-dev:/opt/yellowfin/appserver/logs]# telnet auth.smtp.oneandone.co.uk 25
Trying 212.227.15.179...
Connected to auth.smtp.oneandone.co.uk.
Escape character is '^]'.
220 auth.smtp.oneandone.co.uk (mreue101) Welcome to Nemesis ESMTP server
[/code]

I believe the SMTP server does require SSL and not sure about "Send STARTTLS command" but I have tried all combinations of settings and all return the same exception message.

Any help would be great as I stumped and Googling the exception gives plenty of results but none that seem to make much sense from a user perspective.

Many thanks

Alex
Sorry meant to say we're on version "yellowfin-20140627-update.jar"
Hi Alex,

could you please try adding the following line to the catalina.sh file (/appserver/bin), just put it after the other JAVA_OPTS lines:

[code]
JAVA_OPTS="$JAVA_OPTS -Dmail.smtp.localhost="
[/code]

and then restart Yellowfin. Please let us know if that resolves the issue.

regards,
Dave
Thanks for the suggestion but its still failing with the same exception.

Just to double check I have done the change correctly:
[code]
/usr/java/jdk1.6.0_31/jre/bin/java -Djava.util.logging.config.file=/opt/yellowfin/appserver/conf/logging.properties -Xms128m -Xmx512m -XX:PermSize=64m -XX:MaxPermSize=128m -Djavax.xml.soap.MessageFactory=org.apache.axis.soap.MessageFactoryImpl -Djavax.xml.soap.SOAPConnectionFactory=org.apache.axis.soap.SOAPConnectionFactoryImpl -Djavax.xml.soap.SOAPFactory=org.apache.axis.soap.SOAPFactoryImpl -Dmail.smtp.localhost=auth.smtp.oneandone.co.uk -Djava.util.logging.manager=org.apache.juli.ClassLoaderLogManager -Djava.awt.headless=true -Djava.endorsed.dirs=/opt/yellowfin/appserver/endorsed -classpath /opt/yellowfin/appserver/bin/bootstrap.jar -Dcatalina.base=/opt/yellowfin/appserver -Dcatalina.home=/opt/yellowfin/appserver -Djava.io.tmpdir=/opt/yellowfin/appserver/temp org.apache.catalina.startup.Bootstrap start
[/code]

Cheers

Alex
Hi Alex,

well, you did the change correctly! sorry it didn't help. I'm out of ideas for this one, next week our SMTP expert returns to work from a holiday, I will need to ask for his advice on this issue, I hope that's not too long to wait for a response.


regards,
Dave
Hello again Alex,

well luckily I found an email from our SMTP expert giving advice to another client who was experiencing the same error message as you and it fixed the client's issue. I hope it helps you too, here it is:

It looks like this error is due to the server that YF is installed on being unable to figure out it's own DNS host name. Perhaps Yellowfin has been shifted to a different server, or running with a different version of java. To fix it you'll probably need to get a local network admin to ensure that the server has a reverse DNS entry. To check this, get the ip address of the server, and then run the following from the Windows/Mac/Linux command-line:

nslookup


regards,
Dave
Thanks that was the problem.

Due to this still being a test / dev server the hostname used isn't "real". To compound the issue the /etc/hosts file hadn't been updated to match the correct hostname and IP. Fixing the /etc/hosts fixed the issue but I suspect that adding an entry to our DNS server would have also done so.

Cheers

Alex

Thanks for trying Yellowfin

Please complete the form below to request your copy of Yellowfin today.