Forum

This content is now out of date.

Visit Our Community

“No X-axis fields found” appears in log when creating a GIS map chart

Hi,

We have updated to YF 7.1 in our test environment and I am trying to get geopacks to work. I have done the following:

- Imported the "Australia Postcode Pack" from your marketplace
- Imported it into YF 7.1
- Converted the "Postcode" field on Accounts in our existing view to be Field Type = Geography.
- Linked Postcode (now a Geography field) to the Postcode field in the Geopack (Link Type = None)
- Created the attached report (see attached jpg) which I have also filtered to a specific user territory to make the result set smaller

When I create a GIS Map chart based on this report, the report just loads and doesn't proceed. Looking in the YF log file, the following is shown:

Error creating Dataset: java.lang.Exception: No X-axis fields found. GISDataSet requires one.

Have I missed something?
Hi Aaron,

Thank you for contacting us on the forum.

I just wondered if you could tell me which build of 7.1 you are using?

I have just tested this in 7.1, build 20140923 and unable to replicate. I did consult me log which had the same error message as yours but the chart worked fine.

Once I have the build you are using I will do some further investigating to see why this is occurring.

Kind Regards,
Katie
Hi,

We are actually on an interim build that David supplied us due to some issues we were having with some integration we are working on.

The build number is 20140905.

Thanks,
Aaron
I have also just restarted the YF service and the issue still appears.
Sorry, I appear to have accidentally marked this thread as answered. I still require an answer to this please.
Hi Aaron,

Thank you for sending through the extra information. I have tested in the same build as yourself but I am still unable to replicate.

So where to next? ???Well, there are a couple of things I wondered if you could look at, to see if we can work out why this is happening.

1/ Run Info threads
Can you send across the results from Info_threads results when the chart is not loading(http://:/info_threads.jsp) it will show exactly what YF is doing at that very point in time. This can be accessed by opening a new browser tab and adding it to YF URL. E.g http://localhost:8080/info_threads.jsp

2/Check for any JavaScript Errors
When working on the report view the Java Script Console. In Chrome, head to View>Developer>JavaScript Console. The console will open at the bottom of the browser. Screenshot any errors that appear when you try to create the chart.

Also any screenshots of the chart page not loading so we can see what appears on you instance.

If you would prefer, you can send this information through to support@yellowfin.bi and reference this post.

Hopefully ones of these will give us the information we need to see why the chart is not loading.

We look forward to hearing from you.

Kind Regards,
Katie

Thanks for trying Yellowfin

Please complete the form below to request your copy of Yellowfin today.