Forum

This content is now out of date.

Visit Our Community

Non-acrive fields in a view. Error-message enhancement

When i alter an active view e.g. by adding a calculated field or a custom function than i explicit have to activate those fields. When that isn't done, the program raises an error on activating the view that there are still inactive-fields that will be maintained in draft-mode. But it doesn't mention which fields that are.

Is there a simple way to find those fields or can this message be enhanced?
Hello,

Thank you for reaching out for support and posting your question on our forum.

Is it possible to tell us which version and build of YF you are currently using? E.g, Yellowfin BI 7 - build 20140825.

Additionally, can you send through a few screenshots - where you are altering the view and also the error screen?

This should help us to find out what's going on and if what you are after is indeed possible, or could be added as an
enhancement.

Thank you,

Kyle

Hallo Kyle,

i had forgotten to login when i entered this post. So i couldn't alter anything after posting. This (again) is a post by Peter Lasker.

I got the message in Yellowfin 7.1, latest build. I thought it was rather obvious what happens so i didn't add any screen-shots.

This morning i tried to replicate by putting a "custom function field" into a view without adding any parameters, which is of course an situation that can not be activated

Forum image

However i was able to activate the View and didn't become that error-message. But should this be allowed, activating such a view?

As a second test i tried to add the parameters and saving it without activating this field.

Forum image

The same situation. The field isn't activated but the view can be activated; again no error-message. The same thing happens when i add a normal calculated field with an incomplete case-when statement. To my opinion this might not be activated also.

I did some other testing on draft-fields. I put a field into draft-mode although this field was used in an active formula-field

Forum image

Also while activating the view there came no error-message. Which should have been there... the view can not generate any data based on it's SQL-script


These testing was done in the "Edit Existing"-mode.

Yet, i have more the one problem:
1) i am rather sure that i've seen that error-message warning me that i'm about to activate a view with non-active fields. But i can't reproduce it. Maybe your developers can trace that kind of message

2) i can understand that i can activate a view when i add a field and do not activate it. For testing and developing views this is a great option, while you don't get locked when you have to leave the view. Although also "cloning" could give you this freedom. But, it can be a real problem when you don't get output on your report any more and think that you're view is alright while it is indicated as "Active" (in a situation like the last example)

3) Activating an view with non-active fields may be allowed until i use the field on a report (which is traced by the usage-list of the field) or it is used in a calculated field (which is also in the usage-list, well done!)

Although i couldn't replicate the message, it would be nice if this warning can be activated in the situations described at 2 and 3 and... if possible including information about the one or more fields causing this error.
Hi Peter,

Thanks for the detailed info.

To sum everything up;

-If you have a DB column in 'draft' then 'SAVE' the view, not 'activate' , you will get that warning.

I have created an enhancement request so that draft columns are listed (TASK ID = 173524).

I hope this covers what you were seeing and let me know if I've missed anything, as I know a few other things are mentioned here, but cannot work out if you wanted to raise enhancement requests around them.

Thanks,
David



Hello David,

i have always thought that "activate" was then same as "save"+"status update from draft to active".

Is that right? And if so, will then the error-message also by raised when you "activated" a view?
Hi Peter,

The 'Active' does indeed save and Activate the view.
Though it doesn't perform the same validation.

I know they should really do the same thing, so it has been discussed the best way to clear this up .

Sorry I cannot tell you how it will change, as the dev team will decide the best thing to do.

Thanks for the feedback!

Regards,
David

Thanks for trying Yellowfin

Please complete the form below to request your copy of Yellowfin today.