Forum

This content is now out of date.

Visit Our Community

Problem With conditional formatting reseting to one condition only

Hi,

While i was making conditional formatting alerts (advanced option), the yellowfin client removed all my alerts and only displayed the last alert i made.

I tried to recreate the problem in a different report but it worked fine.
its not the first time it happened and i don't know what causes it.

here is a video on the matter.

LINK

I am using the yellowfin 7.1 build 20141029

I will appreciate your help in the matter

Shaul
Hey Shaul,

Thank you for posting your question on the forum and for
including the screen share, always very helpful.

I've attempted to replicate the issue you are experiencing in
version 7.1, build 20141029 and was not successful.


Forum image


I've also searched our records to see if any other clients
had a similar issue and couldn't locate anything specific.

Is there anything else you can add that might help us
replicate this?

In the meantime I will continue to look at this for you.

Thank you,

Kyle
Hi,

Here is a video taken on the latest version of yellowfin (7.1 20150123).
As you can see the problem starts when i try to implement conditional formatting on a 2nd column.

Video

I managed to replicate this problem on 2 different computers with different web clients and databases.

It's a major problem for me cause i need to implement conditional formatting for a few reports for a client in a project with a tight schedule.

I appreciate any help in the matter.

Saul
Hello Shaul,

I've replicated your issue and raised a defect (#187736) to be looked
at and fixed.

Please let us know if there is anything else.

Apologizes for the inconvenience this has caused.

Regards,

Kyle

Hi Kyle,

We are also facing this same issue within several of our reports. Has there been a resolution to this defect?

Thank you,

Adam
Hi Adam,

Based on the case notes from our Dev team they were unable to replicate this issue in the Feb build of 7.1 and feel it was related to another defect that was fixed in the January build.

So, if you are on a new build and are still seeing this can you provide detailed steps and screenshots so that we can attempt to replicate. And, if you have the tutorial ski team data, replicating it using that will likely expedite the process.

Thank you very much,

Kyle
Thank you Kyle.

I used a different measures in the ski team data (Athlete ID and Invoiced Amount), but went through the same steps as Shaul did and faced this problem.

I have attached a series of screenshot and the issue persists when trying to add multiple alerts on advanced conditional formatting for the second field to which it is applied. The first field always works correctly, the second field will only allow one advanced alert.

In the screenshots, I had already formatted multiple advanced alerts for the Athlete ID measure. Attempting to assign multiple advanced alerts to the Sum A measure failed (C4 replaced C3).

Please let me know if additional screenshots are necessary.

- Adam
Hi Adam,

Thank you for all the detailed information. Can you please tell us which version and build of YF you are currently using. If you don't know, you can find this by going to the Admin console and hitting 'system information'.

Thank you,

Kyle
My apologies.

I think we were using an older build. I upgraded to the latest one released July 31st and the issue is resolved.

Thank you for the help!

- Adam
Hi Adam,

Thank you for letting us know. That is great news.

Regards,

Kyle
Installing the latest build bombed all of our views and reports and will not take a .xml backup to recreate them. Is there a way to downgrade builds?

- Adam
Hi Adam,

You can definitely roll back your version of Yellowfin if needed.

The below forum post outlines this process:

Is it possible to roll back an application upgrade?

Out of curiosity, what version of Yellowfin are you upgrading from? Upgrading should definitely not have the impact you are describing, so we are wondering if something else could be going on here.

Please let us know if you have any questions or concerns. We look forward to hearing back.

Cheers,

Dustin

Thanks Dustin. We will look into this. More than rolling back the version, we are looking to roll back the build. Is a downgrade of the build possible instead of a version downgrade?

I believe we upgraded from Application Version 7.1 and Build 20140827.

Thank you,

Adam
Hi Adam,

Unfortunately you can only roll back to a version of Yellowfin that you have previously installed.

If you are trying to use a version of Yellowfin that is perhaps a couple months older than what you upgraded to, you would need to roll back to 7.1 20140827 and then upgrade to the specific version you would like to install.

Does that clarify things a bit?

Regards,

Dustin
Hi,

May you please tell us the steps to Restore the application directory.

When i replaced root folder in yellowfin then it is giving some error.


Forum image



-Yatendra
Hi Yatendra,

It should just be a matter of unzipping the root-backup.zip file located at:

/backup/yfpatch-XXXXXXX

And then copying the contents of the root-backup folder into the Root folder located at:

/appserver/webapps/Root


Forum image


Make sure that you select 'Replace All' when asked whether or not you would like to overwrite files.

Also, this should be done while the Yellowfin service has been stopped.

Please let us know how it goes.

Cheers,

Dustin
Hi Yatendra,

Per our previous conversation, could you please send in your Yellowfin logs located at YourYellowfinInstallPat/Appserver/Logs to support@yellowfin.bi.

Just zip up the entire logs folder and send them our way so that we can review and try to help you figure out what's going on.

We look forward to helping you solve this problem.

Cheers,

Dustin

Thanks for trying Yellowfin

Please complete the form below to request your copy of Yellowfin today.