Forum

This content is now out of date.

Visit Our Community

Restricting a view with an user group isn’t working

Hello support,

YF Version: 7.1
YF Build: 20140923
Java version: 1.7.0_65
OS: Linux 3.4.91-x1-64 (amd64)

I have encountered a problem with restricting a view with an user group. I imported YF prebuilt content to our YF server and imported the view as well.

I tried to restrict the view so that just our admins will see the reports with our administrator group, but after this restriction no one can see the reports. If I add all of the administrators manually, then they can see the reports correctly. To me this seems this is not working correctly, but please correct me if I'm wrong.

Br. Simone
Hi Simone

Sorry about the restriction issues you are having.

I did a test here and was able to restrict viewing with a User Group setup.
I created a Admin User Group and had 4 users with a role of Admin in it.
Then I excluded one off those admins. Once doing so 3 of the users could view the test report and the excluded one could not.
Only difference here I am using our latest build 20141029 of version 7.1 (which is available for you).

-Could you please send a screen shot of your User Group details page that is giving the issue?

Thank you
Mark
Hello,

I tried the same configurations on another YF server (version:7.1, build: 20140923) and I was able to replicate the issue. Note: We are using client organisations on both installations. The views are created and restricted on the primary organisation since our admins are in this one. The point for all of this is not to show client organisations content from the YF repository.

I tried to replicate this issue with another YF installation (version:7.1, build: 20140827) that has no client organisations but I was not able to. As you can see, the build is one earlier than the ones with client orgs, so I can't be sure the client orgs are the issue here.

My user has Admin rights:

Forum image


It belongs to the "Administrators" group:

Forum image


The view in question is restricted:

Forum image


Here are the settings for the restrictions:

Forum image


Dashboard has no reports, since I have no rights to see them:

Forum image



Could you reply if this is not an issue in the newest build?

Br. Simone
Hello,

I updated to the latest build (Oct. build) and now the user group restrictions seem to work fine.


Forum image


Br. Simone
Excellent !

It definitely sounds like you found a bug in that particular build of 20140923.
Good to know it was fixed in the current build and Great to hear you're group restrictions are now working!

Have a great weekend Simone!

Mark

Thanks for trying Yellowfin

Please complete the form below to request your copy of Yellowfin today.