Forum

This content is now out of date.

Visit Our Community

Setting up Apache mod_jk in ssl VirtualHost

I'm having problem moving my apache mod_jk configuration form its own VirtualHost configuration into my main ssl configuration.

Yellowfin is working ok using a cname and it's own mod_jk VirtualHost configuration:

[code]
LoadModule jk_module /etc/httpd/modules/mod_jk.so
JkWorkersFile /etc/httpd/conf.d/workers.properties
JkShmFile /var/log/httpd/mod_jk.shm
JkLogFile /var/log/httpd/mod_jk.log
JkLogLevel info
JkLogStampFormat "[%a %b %d %H:%M:%S %Y] "


ServerName
DocumentRoot /opt/yellowfin/appserver/webapps/ROOT
DirectoryIndex index_page.jsp


Options FollowSymLinks
AllowOverride None



AllowOverride None
Options FollowSymLinks
Order allow,deny
allow from all


JkMount /* ajp13

[/code]

however because I want to embed my yellowfin reports in my main server pages which are ssl (can't mix http and https) I need to move my mod_jk configuration into my main ssl VirtualHost as a subfolder. I've tried the following changes, but I get a 'HTTP Status 404 - /yellowfin/' when trying to access https://
New server config:
[code]


...lots of my main ssl server config stuff...

Alias /yellowfin /opt/yellowfin/appserver/webapps/ROOT

JkMount /yellowfin/* ajp13


AllowOverride None
Options FollowSymLinks
Order allow,deny
allow from all
DirectoryIndex index_page.jsp



[/code]
This turned out to be an Apache Alias problem. Actually I couldn't get mod_jk to work with an Apache Alias, so I placed Yellowfin in the Apache DirectoryRoot (the original config but with ssl turned on) and used:

[code]
SetEnvIf Request_URI "/content/*" no-jk
Alias /content /path/to/content
[/code]

to enable the non-Tomcat content. Readers should also check (if they're using this technique) to see if they then need to add a RewriteBase /content to their .htaccess file.

Thanks for trying Yellowfin

Please complete the form below to request your copy of Yellowfin today.