This content is now out of date.

Visit Our Community

Share private reports with HTML-layout

I have a report with private access-rights. With my YF 7.0 (build 20140731) i can send this report to an email-adress in PDF-format. However when i choose HTML nothing seems to happen and i receive nothing in my (external-)mailbox. Might i be that reports with summary-data in the header can't be exported as HTML. This seems to be the difference in the reports that can or can not be exported? Should however in that case the HTML-option not been disabled or a message toe be sent?

Another question:
In the attachment i put a screenshot of the task i use to send the report. In this task the button "EMail" is highligthed and so given me the opinion that clicking this button will do something..... but i think (and hope) it does nothing. Is that right? Might it be that the button is highlighted while by private reports you also have options like "Embedded"? In that case i think the button shouldn't be highlighted when there is only one option to share the report.
Hi Peter,

I have tested this in my instance of YF 7.0 20140730 and unfortunately cannot reproduce the issue. I have double-checked my configuration, here I have a report with a Summary and I make it a Private report:

Forum image

and I give user1 Read access to it:

Forum image

and then I email it as HTML to user1 and the email arrives correctly:

Forum image

Therefore it is not a problem with the Summary, or HTML or that build of YF. Could you please send us the Email.log and the Yellowfin.log files (please reference this subject of this forum post), hopefully there will be something useful logged there.

Regarding your 2nd request, I have raised an Enhancement request for it so that it will be implemented in the future, the Support Task ID is 172369

Hallo Dave,

i tested it again, but with same results. So it might have something to do with the configurations of my mail-system.

Another question.
When i try to mail a report the menu defaults to "default value" and not "current values". In my case i use list-boxes with all the items selected. The reports starts with these "all items" by having the system to remember my last selection..... otherwise all list would have been deselected and so my report wouldn't display any records.

So for the user the state with the "all selected list" looks like the default. But when he tries to send the report "with the default value" as selection, he becomes a error-message... although the displayed report on his screen shows a good and complete list and he didn't change any filter-value.

Forum image

Can i change the default "Distribute this report using:" myself or can it be system wide defaulted to "Current values" so that what you send is always the same as what you see. Particularly when you send a report per mail, the default makes no sense in most cases and it is farmost the "current value" that you 'll want to report.
Hi Peter,

unfortunately it is not possible for you to change the default filter option from "Default Values" to "Current Values" for the Email channel. I even checked for you whether it might be possible via the backend but the developer said no. However because it is a good idea of yours (I should actually say another good idea!) I have raised an enhancement request so that it may be implemented in the future - the support task ID is 173001.

thanks for your input,

Thanks for trying Yellowfin

Please complete the form below to request your copy of Yellowfin today.