Forum

This content is now out of date.

Visit Our Community

Source Filter Not Applying for Existing Reports

Hi Team,

I did source filter setup and faced some problems as described below.
[/b]
Problem 1:
Step 1: I have created a source filter and applied that to a View.
Step 2: Created a report based on that view.
Step 3: Verified the report data and filter is worked fine as expected.
Step 4: Now created an another source filter and applied that to same view.
Step 5: When validating the result for the existing report, the second filter is not applied.

Step 6: Created a new report. Both filters are applied automatically and worked fine.

Clarification:
Why the second filter is not applied to the report which is created initially? Is that anything we are missing which will help to apply filter for existing report? Please clarify.

Problem 2:
In version 7.1, how to apply the source filter to a report which is created based on 'FreehandSQL'.
Steps:
1) From the dashboard page, click Create --> Report --> from the dropdown select FreeHandSQL --> A Regular Report radio button --> Select a datasource --> click 'Click Here To Continue' button.
2) After that user can specify the SQL query and can design the report. How to apply the source filter to this report?
Hi Chandra,

Thanks for sending these questions in.

In response to your first problem, not applying a new Source Filter (now called an Access Filter in 7.2) retroactively to an older report is expected Yellowfin behavior. This functionality is implemented so that when a user creates new Access Filters there won't be any unexpected knock-on effects in previously created reports.

In order to apply a new Access Filter to an older report, you must edit the old report and enable the new Access Filter. This can be done by editing the report and going to the Data tab. Near the bottom of the page there should be a checkbox to enable your new filter and apply it to the report.


Forum image


However, this requires that the login that you're using has the appropriate permissions. To see this checkbox, your user must have the Access Filter permission enabled (underneath 'Report Builder').


Forum image


In regards to your second question, it is not possible to create a Freehand SQL report that also has Access Filters applied. This is because Access Filters are applied at the View level, after all of the database information has been pulled into Yellofin. Freehand SQL reports, however, bypass the view (and its Access Filters) and directly query the data source.

Hopefully this provides you with answers to your questions! Please let us know if you need any additional information.

Thanks,

-Conner
Hi Conner,

Consider there are 10 reports designed under a view and after that we have applied the source filter for that. So I have to do the above mentioned setup(edit a report and set access filter) for each report. It will be a rework and if no of reports are high it will take more time to do.

Is there any other way to do this or can enhance this functionality?

Please suggest.

Regards,
Chandrakumar.N.

Thanks for trying Yellowfin

Please complete the form below to request your copy of Yellowfin today.