Forum

This content is now out of date.

Visit Our Community

Unable to connect Mobile app via SSO

Hi,

1. Connecting via Ipad :

Without SSO(http://server_name:port) able to connect Yellowfin Mobile app.

With SSO(https://server_name:secure_port) we are getting error "Test connection was unsucessfull".

2. Connecting via Android 4.2.2 :

With or without SSO we are getting same error "The server failed to respond. Please verify your connection settings, internet connection and try again".

I have attached server.xml file and we are forwarding the request through Tomcat.

Could you please let us know how to integrate SSO with mobile app.

Thanks,
Dhrati
Hello Dhrati,

I have responded to you as well from the case you submitted via email. I will reach out to our
team to see if we can assist you on your issue, via this forum, sooner, rather than later.

In the interim, I have included this post -

Mobile App

which may, or may not, assist you. I've also included the latest Wiki on SSO.

Administration Service

Can you also pass along your system info (version & build of YF)?

Thank you,

Kyle


Hi Kyle,

We are using Yellowfin 7.1 Feb Build.

Thanks,
Dhrati
Hi Team,

Our current setup, we are accessing the Yellowfin reports with sso integration system. The authentication happens through SSO and then redirects to yellowfin application page and its not integrated with Iframe.

We are testing the Yellowfin mobile app i.e., android & Iphone apps. After keying the Users and server details, do get a error while testing says testing unsuccessful. Can you provide us more details how mobile app works through SSO integrated systems, is there any other settings needs to be configured to access through mobile apps.

Current YF version - 7.1
Patch - yellowfin-20150225-update


Regards
Shashi

Hello Shashi,

Thank you for the additional information, and thank you for your patience.

Our level II / Dev team have been notified of your query and its importance
to you and your team. They will be looking at your question and will respond
accordingly.

In the interim, are there any additional logs that you are able to forward that
would shed more light on the error you are receiving? If so, can you zip those
up and send them through?

Thank you again,

Kyle

Hi Kyle,

We verified Catalina log file, no logs are getting captured while testing the mobile app. As said previously, the authentication happens through SSO and then redirects to yellowfin application page.

Regards
Shashi
Hello Shashi and Dhrati,

Thank you for letting us know about the logs. I have reached out again for assistance in getting
some feedback on this issue for you. I hoping to hear something today.

Thank you,

Kyle
Hi Shashi,

I think the problem here is that the mobile application was designed to connect directly to the Yellowfin server. It was not designed to connect to a custom page/application/site, that then re-directs to the Yellowfin application.

Unfortunately the mobile app will not work with SSO.

In order to use Yellowfin on mobile device for your environment, you will need to use a mobile browser.
Alternatively, you can have the mobile app connect directly to Yellowfin.

Really sorry for the bad news, and hopefully this is something that can be considered for a future release, though at this point in time, it is not currently planned.

If I have misunderstood your issue, or if you have any questions/concerns please let us know.

Regards,
David

Hi David,

Is there any plans to make to work with SSO in future?

Regards
Shashi
Hi David,

As an alternative method, we are setting up another instance to talk directly to Yellowfin application.

We are integrating LDAP with Yellowfin application, able to setup the users the only issue facing here is assigning the client org to respective user. When user login for the first time by default user is part of default client org and could not find a way to assign the client organization for LDAP users. In one of the ticket, it was mentioned this issue will be addressed in 6.4 release
[http://www.yellowfinbi.com/YFForum-Default-Client-Organizations-for-LDAP-Users-?thread=125349].

Our current YF version - 7.1
Patch - yellowfin-20150225-update

Can you please suggest how do we assign client organization for LDAP users who login for the first time?


Regards
Shashi
Hi Shashi,

In terms of your SSO issue.
I believe you have also emailed this across.
In this case, you can track your request via the ID 193029.

However, at this point in time, there are no currently plans to support SSO from the mobile Yellowfin application.

The mobile application will need to connect directly to your YF server.

If you wish to use SSO on a mobile device, you will need to use your mobile browser.

Sorry for the bad news

Regards,
David

Thanks for trying Yellowfin

Please complete the form below to request your copy of Yellowfin today.