Forum

This content is now out of date.

Visit Our Community

“Unknown operator: MAXIMUMDATE” appears in log

Hi,

I have a report that is setup something like the following:

Account Name
Question
Brand Answer is against
Answer

When I run this report with no filters, although slow (40 seconds to return 300-odd rows) it works without any issues.

The issue comes about when I apply a filter to the report which is "Date Answered" and set this filter to "Maximum Date" in the "Configure Filter" screen. I want to do this because I only want the LAST answer to the question for the account.

The report simply doesn't run. Checking the yellowfin.log on the server, I can see the following error:

YF:2014-08-05 04:42:07:ERROR (ReportFilterProcess:loadFilterValues) - Error: java.lang.Exception: Unknown operator: MAXIMUMDATE

When the Maximum Date filter is removed the report works fine again.

Is this a known bug or is there some kind of work around? Or am I doing something wrong?

I am using Yellowfin 7.0 build 20140528.

Thanks,
Aaron
Hi Aaron,

As you are using an older build of Yellowfin, if possible we would recommend
upgrading your YF instance to the latest build, as of 30th July 2014.

Latest build is available here.

While this may not immediately correct your issue, it will assist us in pinpointing your problem.

Keep us updated on your progress.

Kind Regards,

Danny
Hi Danny,

I have updated our test environment to the latest version (20140730) and re-tried this report.

When run WITHOUT the "Maximum Date" filter: report runs in 143 seconds (361 rows returned).

When run WITH the "Maximum Date" filter: report runs for over 4mins and then returns the message "Error retrieving results. An error occurred retrieving the results from the database"

Interestingly, I apply an additional filter to the report to run for a much smaller number of accounts (e.g. accounts for a specific user rather than nationally) the report works just fine with the "Maximum Date" filter (31 rows in 21 secs). Is it a timeout issue? Any way to increase the timeout?

Thanks,
Aaron
Hi Aaron,

I've run a few test against HSQL and SQL Server but cannot run into any performance issues or any errors.

I'm wondering;

-Does this date filter use another table which then changes the report SQL.
Maybe it has to join more tables etc..
-What is the underlying DB, and data type of this date filter.
-How is this date field setup at the view level?
-Can you get the the report sql when using a date filter (choose a date that will return results) , then run this directly against your DB and let me know how long it takes to run?

In terms of changing the timeout, it's done at the data source connection details as shown here: How to configure the timeout settings for a database connection

Also, do you still get the error in the logs 'Unknown operator: MAXIMUMDATE'
If so, can you send across the Yellowfin logs (just everything in the yellowfinappserverlogs).

Please let me know your findings.

Regards,
David
This issue is sorted. I changed the logic of the report and eventually got it to work by re-working it.

Thanks for trying Yellowfin

Please complete the form below to request your copy of Yellowfin today.