Forum

This content is now out of date.

Visit Our Community

Webservice DRILLANYWHERE command throws exception

I am using the yfws-20140827.jar to display and interact with reports in our java web application. Our application has a jsp with widgets, where each widget loads a Yellowfin report with an AJAX load. The list of Yellowfin reports is pulled from the dashboard of the current user.

A couple notes:
1. I am able to load the reports.
2. I am able to issue javascript commands to such as javascript:postCommand('DRILL|68897|68926|NONE|68927=Q2lzY28gTGl2ZSBPbmxpbmU_3D'); and it works fine.

Problem:
I am NOT able to issue a DRILLANYWHERE command (on an appropriate report), without an exception being thrown. The exception is:
java.io.IOException: No serializer found for class com.hof.mi.web.service.DrillTarget in registry org.apache.axis.encoding.TypeMappingDelegate@3e2790e0
at org.apache.axis.AxisFault.makeFault(AxisFault.java:101)
at org.apache.axis.SOAPPart.writeTo(SOAPPart.java:317)
at org.apache.axis.SOAPPart.writeTo(SOAPPart.java:269)
at org.apache.axis.Message.writeTo(Message.java:539)
at org.apache.axis.transport.http.AxisServlet.sendResponse(AxisServlet.java:902)
at org.apache.axis.transport.http.AxisServlet.doPost(AxisServlet.java:777)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:643)
at org.apache.axis.transport.http.AxisServletBase.service(AxisServletBase.java:327)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:723)

I have attached a JSP that is used to load the Yellowfin report. I've taken out some caching and simplified it a bit so it can be analyzed easier.

NOTE: As I render each report, I override the LinkURL to add the reportId and tabId to reference the appropriate report widget, and the COMMAND is sent to the rendering JSP (included JSP).

I have also tried calling this method, when the DRILLANYWHERE is issued, but before the report is run:
reportClient.getDrillAnywhereMenu(69005, 1, "drill text", "drill text"), but it is throwing a NullPointerException on the Yellowfin install.

I've also tried enabling JAX-webservices as described here:
http://www.yellowfinbi.com/YFForum-How-to-enable-JAX-web-services-?thread=158117

I've also attached a screenshot of the working DRILLANYWHERE report directly from the Yellowfin interface.

Any tips would be appreciated.
Thanks, Mike

Screenshot from yellowfin interface


Forum image
Hi Mike,

Sorry for the delayed response.

It looks like currently there are no classes to support drill-anywhere via web services.
A task has been raised (TASK ID = 178225) and assigned to the dev team.

Which version of Yellowfin are you currently using?

Apologies for the inconvenience with this.


Regards,
David

I am currently running 7.1 (20140827).

Also, is appears that Yellowfin chart brushing is not quite working thru web-services. I can draw the "square" to select the specific data elements, and get the "include/exclude" dialog to show, but clicking on those links don't go thru the regular postCommand('##'). Can you please confirm this?

Thanks,
Mike Bushman
Hi Mike,

Unfortunately your findings are correct.
I have raised a support task (TASK ID = 179136) so that we can support chart brushing with web services, and in the interim, to at least stop the widget from displaying for active charts.
I cannot give an ETA as yet, as it's yet to be discussed with the dev team.

Really sorry for the inconvenience this has caused.

Regards,
David

Thanks for trying Yellowfin

Please complete the form below to request your copy of Yellowfin today.