Forum

This content is now out of date.

Visit Our Community

XMLA OLAP connection to SQL Server 2014 : Cube List empty

Hi Team,

I am using Yellowfin 7.1 trial.
I am trying to connect to an OLAP Cube housed within a SQL Server 2014 instance.

When creating a DataSource, trying to connect using XMLA OLAP method, My Database is listed under Catalog, but my Cube does not get listed.

ERROR:
Oh no! An error occurred loading your details from the database. Please try again later

Please review the attachments, and help me fix this.

Regards,
Alekh Jain | itwizalekh@gmail.com
Trying to post attachments again.

Forum image


Forum image
Showing Cube List Empty.

Forum image
Hi Alekh,

could you please zip up and email us (support@yellowfin.bi) the log files from appserverlogs.

Also, just curious if you tried Standard Authentication instead of Pass Through, and if so how did it go?

regards,
Dave
Hi Dave,

Thanks for your response.

The sent the logs to support@yellowfin.bi

I also tried Standard authentication, and I could still not see my cube in the Cube list (screenshot attached).


Forum image


Regards,
Alekh Jain | itwizalekh@gmail.com
Hi Alekh,

thanks for the logs and sorry for the delay in responding. We can see the following error:

[code]YF:2015-03-05 10:16:18: INFO (MIDataSourceEditAction:execute) - MIDataSourceEditAction entered
YF:2015-03-05 10:16:18: INFO (MIDataSourceEditAction:execute) - MIDataSourceEditAction exiting with action: success
YF:2015-03-05 10:16:31: INFO (MIDataSourceEditAction:execute) - MIDataSourceEditAction entered
YF:2015-03-05 10:16:32:ERROR (MIReportProcess:loadCubes) - Error: com.hof.mi.olap.OlapException: java.lang.RuntimeException: Unknown locale en_IN
YF:2015-03-05 10:17:30: INFO (MIDataSourceEditAction:execute) - MIDataSourceEditAction entered
YF:2015-03-05 10:17:30: INFO (MIDataSourceEditAction:execute) - MIDataSourceEditAction exiting with action: success
[/code]

which unfortunately we are not familiar with, however we are wondering whether it's an olap4j driver issue, so we have to ask you to make sure you are using the latest version of the driver.

Also, we think it could be worthwhile to change the locale en_EN and see whether that resolves the issue. Not sure whether it's referring to the locale of the server, the database or the JVM, but I guess you can work that out by checking which of them is configured for en_IN.

please let us know how you go with this.

regards,
Dave
Thanks again Dave.

After some struggle, I figured-out that changing the format from English(India) to English(Australia) worked for me.

Regards,
Alekh Jain
Hi Alekh Jain,

that is certainly great news to hear, thank you very much for sharing it with us!

regards,
Dave
Hi Alekh Jain,

I am encountering exactly the same problem as stated above of not being able to view the built cubes. Glad that you got this addressed by changing the format from English(India) to English(Australia). Can you please mention the steps you followed to make the locale/language change and was it within Yellowfin or SSAS or JVM?

Thanks in advance.

Regards,
Kishore
With upgrade to ver 7.1 build 20160223, this problem is solved. It now doesn't matter if the JVM locale is set to en_IN(en).

Steps to be followed:
1. Upgrade to the latest build 20160223
2. Run the following SQL statement in the Yellowfin DB table:

INSERT into Configuration (IpOrg, ConfigTypeCode, ConfigCode, ConfigData)
VALUES (1, 'SYSTEM', 'OLAPCONNECTIONLOCALE', 'en_US');

3. Shutdown Yellowfin. Restart Tomcat server and login to Yellowfin.
4. If the OLAP connection under Data Sources is now tested, SSAS cubes will appear in the "Cubes:" section.

Thanks for trying Yellowfin

Please complete the form below to request your copy of Yellowfin today.