Forum

This content is now out of date.

Visit Our Community

Yesarly comparison

The Yearly Comparison option is not working on some events.

I'm working with date that span over 2 years, line chart.
Some times I get the option and some time not.

Do you have the exact rules to enable this option?

(I'm using version 7.1, last build)


Forum image
Rami,

Sorry to hear that you are having issues with the Yearly Comparison Option.

I have been able to replicate your issue in 7.1 on our end.

I will forward this info on to the Melbourne office for verification and
let you know the what the next step is.

Thank you,

Kyle

Thank You. I Don't think it is a bug. I think you must meet certain rules in order to use the yearly comparison option. I'm looking for those rules.
Rami,

The Time Format option is only available if Time Series is 'on' -

This can be done in the chart builder by clicking on the arrow of the field. See attached screen shot.

YF does not treat it as an event until Time Series has been collected.

Please let me know if this answers your question.

Cheers,

Kyle

From my original post (and the attached picture) you can see the Time Format option that opens only when Time Series is 'on'.
The first option in Time Format should by Yearly comparison, and it is not available.
Also, Time Series 'on' is the default option (in 7.1) when using a date field (Horizontal Axis) and a line chart.
Hi Rami,

Thank you for contacting us with your query.

I have looked into this for you and spoken tot he dev team on how to ensure activate the Yearly comparison.
There are a couple of things we can check that may be causing the issue:
1/ If drill down is turned on the yearly comparison will not be available.
2/ It cannot be used on a cross tab report.

Please let me know if this provides the information you need. If not, please let me know and I will conduct some further testing.

Kind Regards,
Katie
Thank You.
The "Drill Down" is the answer. As it is "on" by default (v7.1), the yearly comparison is "off" till you turn "off" the drill down (No Drill).

Is it a documented feature? I couldn't find it in the WIKI or any other document.
Hi Rami,

Great to hear this fixed the problem.

Yes that is correct, the yearly comparison is off until the drill down is off. Drill Down being set to ON as default is a new feature since the release of 7.1.

The documentation for the 7.1 wiki is currently being worked on and I have noted that this information will need to be added.

If you have any further question or I can assist further please let me know.

Kind Regards,
Katie
Does Yearly Comparison work with OLAP cubes

I followed this thread and have No Drill selected
It is not a Crosstab Report
The Horizontal Acces is set up as a Time Series and turned on

When I went into Settings, I firest selected granularity of Month and the Chart refreshed fine.

When I tried Yearly Comparison, I received an Error saying Please Select Valid Series Data

Thx

Thanks for trying Yellowfin

Please complete the form below to request your copy of Yellowfin today.