Forum

This content is now out of date.

Visit Our Community

CSV Entry Issue


Hi,

In continuation with the issue raised under this thread (http://www.yellowfinbi.com/YFForum-comma-in-metric-field-at-filter-level-?thread=169263)

Numeric field by default is comma separated even after turning off the thousand separator option.Due to this we have issue with CSV entry option for filters.

Eg, Values to be filtered are 62610890,62610891

By default commas are added so my numbers looks like this

62,610,890,62,610,891

CSV entry considers as
62
610
890
62
610
891


Forum image


Do we have a resolution for this.

Thanks,

Suneetha
Hi,

Any update on this issue? Also, this is related to the task 169192 which was already raised by us. However we noticed this using the csv option.

Could you let's know the ETA for this fix? Our users are asking as this is impacting them.

Thanks
Guru
Hi Guruprasad,

we have been able to reproduce this issue over here, so a product defect has been raised, the support task ID is 173448 and has been added to the agenda for the next development meeting.

Regarding Support Task 169192, unfortunately it is too close to this month's patch release date for this to be added, so it will have to be fixed for the October patch instead.

regards,
Dave
Hi Dave,

Please confirm if this is on track to be fixed for Oct patch release. Our users are waiting for the fix as they are unable to use the csv entry for Filters.

Thanks
Guru
Hi Guru,

I have checked the status of this task, it has been allocated to a developer which is a good sign, however, it hasn't been finished yet so it won't make it into the October patch, it will be the November patch instead.

regards,
Dave
Hi Dave,

The above issue is not fixed in the Yellowfin 7.1 nov patch. Please provide an ETA by when it can be fixed.

Thanks,
Dhrati

Hi Dave,

The latest build(Nov-14 patch build) has this item as fixed in the Change Logs. I am wondering what happened? Can you please clarify?

Thanks
Guru
Hi Dhrati and Guru,

I've just tested this in my Nov build of YF 7.1 and it looks fixed for me:



Forum image


I should clarify that this was with the format of the field configured in the view to have no thousand separator:



Forum image



If you tell me the steps you have taken to get this issue then I'll have a go at reproducing it over here.


regards,
Dave
Hi Dave,

In the attached screenshot we have disabled thousand saperator but if we keep any metric field IN LIST filter and type value it automatically takes comma while in the output it shows correct value and moreover if we have a csv entry its not working as expected. If 2014 is provided and clicked on csv entry its 2 as one value and 014 as another value (2,014). PFA screenshot for csv entry.

Thanks,
Dhrati
Hi Dave & Dhrati,

Just jumping in here as I recognized the issue of the thousand
separator and 'in list' usage.

This was brought up by another customer this week and we
have raised a new task for this to be fixed (#180785).

However, I believe this is specific to the thousand
separator setting not applying to a metric when used
as a 'in list' filter. There is no mention of the CSV issue
in this task.

Regards,

Kyle

Hi,

I think we had clearly indicated that this issue happens in metric field used in the filter((http://www.yellowfinbi.com/YFForum-comma-in-metric-field-at-filter-level-?thread=169263). I am not sure what's the gap in understanding. We have been waiting for this since Aug-14 and now I hear there is a new taskId created for this. This is bit disappointing to note as we are going back and forth on this issue that is so easy to reproduce. Please confirm if this is included in the Dec patch release. If not, how long we need to wait for the fix?

Thanks
Guru
Hi Guru,

sorry for the delay in fixing this, the reason it got held up was because the initial support task was fixed, but then it turned out that the bug had returned, however, the strange thing is that I couldn't reproduce the issue (I'll email you a video I made for my colleagues) and neither could a work colleague of mine, but then a third colleague could reproduce it thus the new support task ID was created.

I have increased the priority of the new task 180785 to HIGH so that it will definitely be fixed for the January patch.

Apologies again for the delay.


regards,
Dave
Hi Dave,

CSV entry had a fix in Jan build, however we see this issue pop up in Feb build.

Could you please look into this.

Thanks,

Suneetha

Thanks for trying Yellowfin

Please complete the form below to request your copy of Yellowfin today.